Basket Сетевое оборудование Cisco купить в Москве
Продажа оборудования Cisco, Huawei, HPE

Настройка DHCP Cisco

25 июня 2019

Протокол DHCP позволяет производить автоматическую настройку сетевых устройств. Настройка DHCP сервера на маршрутизаторе выгодна тем, что позволяет по максимум задействовать работающий маршрутизатор, повесив на него максимальное количество функционала (интернет, NAT, DHCP и т.п.). DCHP позволит маршрутизатору автоматически настраивать на клиентах следующие основные параметры:

  • IP адрес
  • Основной шлюз
  • Маска подсети
  • DNS сервера
  • Имя домена

Ниже мы приводим для вас сразу несколько разных инструкций по настройке DHCP на оборудовании Cisco.

 

СОДЕРЖАНИЕ:

  • Видеоурок по работе с Cisco Packet Tracer. Курс молодого бойца по настройке DHCP
  • Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer
  • Листинг команд настройки маршрутизатора R1, на котором "поднят" DHCP сервер
  • Настройка DHCP сервера на маршрутизаторе Cisco, возможные причины неработоспособности сети
  • Полезные команды настройке DHCP Cisco

 

Видеоурок по работе с Cisco Packet Tracer. Курс молодого бойца по настройке DHCP

 

Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer

В этой видео инструкции рассматривается процесс настройки централизованного DHCP сервера в программе Cisco Packet Tracer.

Показано:

  • как настроить пулы динамических IP адресов для различных сегментов локальной сети,
  • как настроить рабочую станцию на получение динамического IP адреса,
  • как проверить наличие получения динамического IP адреса рабочей станцией.

Новые команды для настройки маршрутизатора для получения пула динамических IP адресов у централизованного DHCP сервера.

Для примера рассматривается роутер R1

Настройки производятся в режиме глобальной конфигурации:

R1(config)#interface fastEthernet 0/1 - заходим в настройки интерфейса к которому подключен компьютер получающий динамический IP адрес

R1(config-if)#ip helper-address 192.168.30.11 указывается IP адрес централизованного DHCP сервера.

R1(config-if)#do wr

Building configuration...

 

Листинг команд настройки маршрутизатора R1, на котором "поднят" DHCP сервер, следующий:

R1#conf t

R1(config)#interface Ethernet 0/1/0

R1(config-if)#ip address 172.33.56.1 255.255.255.0

R1(config-if)#no sh

R1(config-if)#exit

R1(config)#ip dhcp excluded-address 172.33.56.1

R1(config)#ip dhcp excluded-address 172.33.56.254

R1(config)#ip dhcp pool R1SW6

R1(dhcp-config)#default-router 172.33.56.1

R1(dhcp-config)#network 172.33.56.0 255.255.255.0

R1(dhcp-config)#dns-server 192.168.40.11

R1(dhcp-config)#do wr

Building configuration...

[OK]

R1(dhcp-config)#exit

R1(config)#do sh ip prot

Routing Protocol is "bgp 1"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

R1(config)#router bgp 1

R1(config-router)#do sh ip route

(фрагмент ответа)

     172.33.0.0/24 is subnetted, 1 subnets

C       172.33.56.0 is directly connected, Ethernet0/1/0

R1(config-router)#network 172.33.56.0 mask 255.255.255.0

R1(config-router)#do wr

 

Настройка DHCP сервера на маршрутизаторе Cisco, возможные причины неработоспособности сети

Рассматривается настройка DHCP сервера на маршрутизаторе Cisco, показаны возможные причины неработоспособности сети, связанные с работой протоколов маршрутизации и варианты устранения данных неполадок.

 

Полезные команды настройке DHCP Cisco

 

  • Исключим из раздачи адрес 192.168.1.254 и адреса с 192.168.1.1 по 192.168.1.9

Router(config)# ip dhcp excluded-address 192.168.1.254

Router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9

 

  • Настройка DHCP пула

Настройка DHCP сервера включает в себя определение пула адресов, которые будут раздаваться. Для создания пула используется команда ip dhcp pool [название_пула]. После этого необходимо ввести две обязательные команды – network [адрес_сети][маска/длина_префикса] для указания сети из которой будут раздаваться адреса и default-router[адрес_default_gateway] для указания шлюза по умолчанию (можно ввести до 8 адресов).

 

  • команда show ip dhcp binding показывает список всех IP адресов и сопоставленных с ними MAC адресов, которые были выданы DHCP сервером.

 

  • команда show ip dhcp server statistics покажет статистику DHCP сервера, включая информацию об отправленных и полученных DHCP сообщениях

 

  • Ретрансляция DHCP (DHCP RELAY)

Команда ip helper-address [адрес_DHCP-сервера] на маршрутизаторе в режиме конфигурации интерфейса укажет ему перенаправлять broadcast сообщения от DHCP клиентов уже в виде unicast к DHCP серверу, находящемуся в другой сети.

 

  • Настройка роутера DHCP клиента

Иногда роутер сам должен получить IP адрес по DHCP, например от интернет-провайдера. Для этого нужно в режиме конфигурации интерфейса ввести команду ip address dhcp, после чего интерфейс будет пытаться получить адрес от DHCP сервера.